PrestaShop Confirms Zero Day Attacks Hitting eCommerce Servers

The team behind the open source PrestaShop ecommerce platform has issued a public advisory to warn of zero day SQL injection attacks hitting merchant servers and planting code capable of stealing customer payment information.

An urgent advisory from PrestaShop warned that hackers are exploiting a “combination of known and unknown security vulnerabilities” to inject malicious code on ecommerce sites running the PrestaShop software.

“A newly found exploit could allow remote attackers to take control of your shop,” PrestaShop said, noting that the security defect could expose up to 300,000 third-party merchants to server compromises that expose sensitive data.

“While investigating this attack, we found a previously unknown vulnerability chain. At the moment, however, we cannot be sure that it’s the only way for them to perform the attack,” the team added.

[ READ: SonicWall Warns of Critical GMS SQL Injection Flaw ]

PrestaShop, which has a high-profile Google partnership and is used on shops throughout the U.S. and Europe, has released software patches to cover the known vulnerabilities.

From the PrestaShop advisory:

“To the best of our understanding, this issue seems to concern shops based on versions 1.6.0.10 or greater, subject to SQL injection vulnerabilities. Versions 1.7.8.2 and greater are not vulnerable unless they are running a module or custom code which itself includes an SQL injection vulnerability. Note that versions 2.0.0~2.1.0 of the Wishlist (blockwishlist) module are vulnerable.”

The PrestaShop team said the attackers appear to be targeting shops using outdated software or modules, vulnerable third-party modules, or a yet-to-be-discovered (zero day) vulnerability.

“After the attackers successfully gained control of a shop, they injected a fake payment form on the front-office checkout page. In this scenario, shop customers might enter their credit card information on the fake form, and unknowingly send it to the attackers,” the team said. 

“While this seems to be the common pattern, attackers might be using a different one, by placing a different file name, modifying other parts of the software, planting malicious code elsewhere, or even erasing their tracks once the attack has been successful,” PrestaShop added. 

PrestaShop said the attackers might be using MySQL Smarty cache storage features as part of the attack vector and recommends that shops disable this rarely used feature as a mitigation to break the exploit chain.

PrestaShop also released instructions to help merchants identify signs of infections and recommended that ecommerce provides conduct a full audit of your site and make sure that no file has been modified nor any malicious code has been added.

Related: SonicWall Warns of Critical GMS SQL Injection Vulnerability

Related: Apple Ships Urgent Security Patches for macOS, iOS

Related: Patch Tuesday: 84 Windows Vulns, Including Exploited Zero-Day

view counter

Ryan Naraine is Editor-at-Large at SecurityWeek and host of the popular Security Conversations podcast series.
Ryan is a veteran cybersecurity strategist who has built security engagement programs at major global brands, including Intel Corp., Bishop Fox and Kaspersky GReAT. He is a co-founder of Threatpost and the global SAS conference series. Ryan’s past career as a security journalist included bylines at major technology publications including Ziff Davis eWEEK, CBS Interactive’s ZDNet, PCMag and PC World.
Ryan is a director of the Security Tinkerers non-profit, an advisor to early-stage entrepreneurs, and a regular speaker at security conferences around the world.
Follow Ryan on Twitter @ryanaraine.

Previous Columns by Ryan Naraine:
Tags: