Ubuntu Security Notice USN-5193-1

==========================================================================
Ubuntu Security Notice USN-5193-1
December 14, 2021

xorg-server, xorg-server-hwe-18.04, xwayland vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

– Ubuntu 21.10
– Ubuntu 21.04
– Ubuntu 20.04 LTS
– Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in X.Org X Server.

Software Description:
– xorg-server: X.Org X11 server
– xwayland: Xwayland X server
– xorg-server-hwe-18.04: X.Org X11 server

Details:

Jan-Niklas Sohn discovered that the X.Org X Server incorrectly handled
certain inputs. An attacker could use this issue to cause the server to
crash, resulting in a denial of service, or possibly execute arbitrary
code and escalate privileges.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
xserver-xorg-core 2:1.20.13-1ubuntu1.1
xwayland 2:21.1.2-0ubuntu1.1

Ubuntu 21.04:
xserver-xorg-core 2:1.20.11-1ubuntu1.2
xwayland 2:21.1.1-0ubuntu1.1

Ubuntu 20.04 LTS:
xserver-xorg-core 2:1.20.13-1ubuntu1~20.04.2

Ubuntu 18.04 LTS:
xserver-xorg-core 2:1.19.6-1ubuntu4.10
xserver-xorg-core-hwe-18.04 2:1.20.8-2ubuntu2.2~18.04.6

After a standard system update you need to reboot your computer to make all
the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5193-1
CVE-2021-4008, CVE-2021-4009, CVE-2021-4010, CVE-2021-4011

Package Information:
https://launchpad.net/ubuntu/+source/xorg-server/2:1.20.13-1ubuntu1.1
https://launchpad.net/ubuntu/+source/xwayland/2:21.1.2-0ubuntu1.1
https://launchpad.net/ubuntu/+source/xorg-server/2:1.20.11-1ubuntu1.2
https://launchpad.net/ubuntu/+source/xwayland/2:21.1.1-0ubuntu1.1
https://launchpad.net/ubuntu/+source/xorg-server/2:1.20.13-1ubuntu1~20.04.2
https://launchpad.net/ubuntu/+source/xorg-server/2:1.19.6-1ubuntu4.10

https://launchpad.net/ubuntu/+source/xorg-server-hwe-18.04/2:1.20.8-2ubuntu2.2~18.04.6